PDA

View Full Version : Slow down when scrolling the map



switch_back
26 Apr 04, 07:32
Hi guys, why is it when I scroll the map around, it does so like the computer is struggling to process it, even with just having the unit counters insted of their graphical counterpart it is really laggy when I scroll the screen? :(

Am I doing something wrong?

BTW I have an 800MHz machine 512Mb RAM and 32Mb Nvidia GeForce 2
In case you wanted to know the spec for a reply.

CPangracs
26 Apr 04, 08:31
...BTW I have an 800MHz machine 512Mb RAM and 32Mb Nvidia GeForce 2 In case you wanted to know the spec for a reply.You said it all right there! Your graphics card is, to coin a phrase, a dog. Vice buying a brand new card, you might want to try setting your video card to 2d performance instead of any 3d settings. ATF doesn't use 3d, rather it uses DirectDraw, so you don't need your vid card set for rendering. You must realize that the map in ATF is a fairly large bitmap redrawn every time you move the map across the screen. Because DirectDraw doesn't render ahead (rendering is distinct to 3d programs), it redraws the map every time you move, causing lag.

Oh, and having an 800MHz doesn't help either!:D

switch_back
26 Apr 04, 08:36
Thanks Curt, ill give it a whirl. ;)

Failing that i'll just have to bite the bullet and replace my what has been a faithful graphics card.

I havent tried using my overclocker program yet, so that could be something to try also. Its quite amusing really because I can run POAII perfectly on my machine, but ATF has a bit of trouble, oh well we cant win them all!! :D

KG_Norad
26 Apr 04, 10:54
I up graded my graphic card from 32 to a low end 128 and that did not help much. ATF is very tricky in terms of getting good performance out of it for some reason. I have not yet found the trick myself yet. But good luck. You have similar specs to my machine. Which intrigues me because I wanted to get POA2 and was hesitant.

switch_back
26 Apr 04, 10:58
I think POAII runs well on my machine because when I run games such as that I whack up my virtual memory usage and a few other settings, and have the computer almost completly devoted to running it :D

Its also a matter of how long you want to wait for a turn to process, I can get a large sized turn to process in about 30 minutes, and the smaller ones no longer than 5 minutes, there seems to be a big hole of uncertainty with running POAII, I think buying POAII is more of a hit and miss affair to how it will run on your machine.

Deltapooh
26 Apr 04, 21:10
I have a Nvida FX 5950 256mb video card and the game still slows when all vehicles are visible or in dense terrain.

ATF was a leap in wargaming. As is often the case in such circumstances, not everything landed in one piece on the otherside!

switch_back
27 Apr 04, 04:56
Ive managed to solve the problem last night!! Curt helped with that one, all I did was turn off Direct Draw, there is a tiny bit of slow down, but it is so much better now, such a simple solution for such an annoying problem! :D

Dr Zaius
27 Apr 04, 08:42
I used to have the same problem on my Athlon 1.8 with 512mb RAM and Geforce Prophet III. I messed with the drivers and the DirectX setting and it helped some, but not much. I now have an Alienware 3.0Ghz Pentium IV with 1mb Ram and a Geforce FX 5950. I also still have the same problem.

ATF just doesn't run very efficiently most of the time. I think Cpt Proctor is aware of this and he intends to give the graphics engine an overhaul in AATF. I have ATF installed on three computers at the moment. The two I listed above and a 1.9Ghz Athlon laptop. In some ways, the simulation seems to actually run slower on the fastest machine. I believe the sim is programmed to "scale" some of the number crunching to the abilities of the CPU. Use a faster CPU and it simply crunches more numbers. I could be wrong about that, but it seems that way sometimes.

I find I can cruise around the map very smoothly--as long as no units are on the map. That's what seems to slow everything down. Even the non-graphical unit counters do this to some extent.

Pat Proctor
27 Apr 04, 10:33
Unit zoom level also plays a factor. If you have units at 200% or 100%, they are easier to draw than at some odd zoom level.

Also try

1. turning vehicles off and only drawing platoons and companies
2. Drawing contour or color, not contour over color
3. Turning off all other programs that are running at the same time.

Again, sorry for the issues. We are working to resolve the problem.

switch_back
27 Apr 04, 11:12
Unit zoom level also plays a factor. If you have units at 200% or 100%, they are easier to draw than at some odd zoom level.

Also try

1. turning vehicles off and only drawing platoons and companies
2. Drawing contour or color, not contour over color
3. Turning off all other programs that are running at the same time.

Ive tried all of those Pat they didnt work, but when I disabled direct draw that sorts it out, I have no problem with it now!! :D

Thanks for your input, much appreciated, as far as the game goes this is a minor issue and doesnt really affect the great depth of the game. :thumup:

KG_Norad
27 Apr 04, 11:33
How do you disable direct draw?

CPangracs
27 Apr 04, 14:14
How do you disable direct draw?
There should be a pregram called dxdiag.exe in your C:\WINDOWS\SYSTEM32 Folder. Double-click on it ad then select the Display tab. You will see an area called "DirectX Features". Click on the Disable button next to DirectDraw Acceleration.

Hope this helps!

Curt

switch_back
28 Apr 04, 05:07
Couldnt have said it better myself Curt!! :hail: