PDA

View Full Version : POA2: Shifting the TEC



Dr Zaius
17 Mar 04, 14:45
In the process of creating the new symbol set things are now in slightly different order than they were on the default symbol set. What I have noticed is that even adding one symbol near the beginning throws off the whole TEC if one of the ECX files from the original maps is used. If I use the “link this TEC to map” within the dataview utility to create an entirely new ECX, then everything starts out blank and I will have to manually re-link every single non-cosmetic symbol. Is there some easier way to do this?

HPS
17 Mar 04, 14:48
In the process of creating the new symbol set things are now in slightly different order than they were on the default symbol set. What I have noticed is that even adding one symbol near the beginning throws off the whole TEC if one of the ECX files from the original maps is used. If I use the “link this TEC to map” within the dataview utility to create an entirely new ECX, then everything starts out blank and I will have to manually re-link every single non-cosmetic symbol. Is there some easier way to do this?
There is no way “built in” to the code to shift entries in the TEC link file. So, unfortunately, if you shift the order of the symbols/lines you’re going to need to edit the existing link table, or depending on how different the sets are, create it from scratch. It shouldn’t be that bad, though. I think the current one took Nick less than 30 minutes to do. If you have several symbols with the same name, you only have to link the first one - the computer is smart enough to automatically link the rest. If you have any questions, just let me know.

See ya
-Scott

Dr Zaius
17 Mar 04, 14:59
Damn! :eek:

This means I will have to create a brand new TEC from scratch as the old one is too different to even modify. I can't release the revised symbols until I have a compatible TEC to go with it. Hopefully, this won't take as long I I thought it would.