PDA

View Full Version : ATF color settings



Dr Zaius
07 Oct 02, 15:59
It's too bad ATF only runs in 16 or 24 bit color. It's a real pain to have to go into my video card settings and change them every time I fire up the demo. A lot of games have options to set the resolution and color depth from within the game itself. Perhaps this could be added to a furture version of ATF. That would save us from having to juggle different settings all the time.

Dr Zaius
08 Oct 02, 16:20
Here is another issue with ATF. Why do some of the units have a pink border around them? Has anyone else noticed this in the demo? It must have to do with the way the game is attempting to handle the pink background the units are on. I'm going to play with the bmp files and see what I come up with.

Dr Zaius
08 Oct 02, 16:40
Okay, here is my best guess of what is causing this...

The unit images are compiled into bmp files with multiple images on a single bmp image. Bmp images do not support transparency, but the backgrounds of all the images are the same (Red: 255 Green: 0 Blue: 255). That means that the game must be programmed to make anything that is set to that color transparent when it is displayed on-screen. The problem seems to be that the unit images are resampled in size for the different zoom modes. When the game does this part of the pink color is slightly altered and is no longer transparent. Thus units displayed on-screen have pink garbage around the unit.

That's my best guess. Can someone else fire up the demo and see if they are getting this as well? Let me know what you discover.

Dr Zaius
08 Oct 02, 16:44
Hmmm, in 32 bit true color I still get the same problem, but only on about 10% of the units. That leads me to believe the problem is related to DirectDraw in some way.

Of course, the game is unplayable in 32 bit anyway, but I wanted to test it and see what I came up with.

Pat Proctor
08 Oct 02, 22:58
Gentlemen,

I am a firm believer in not blaming the hardware, but...;)

The color aberations are the result of some driver manufactures failing to comply with the published DirectDraw standard. Unfortunately, I am talking about some major players here, not small operations. So you will see this phenomena on alot of cards.

It can be fixed by doing the following:


Go to your control panel
Click on DirectX
Click on the DirectDraw tab.
Remove the checkmark from "Use Hardware Acceleration"


You will notice, when you do this, that some graphical bugs in some of your other programs clear up as well. It is, frankly, a symptom of driver manufacturers not testing all of the DirectDraw features before the release drivers. In a perfect world, turning off this tab would have no impact on the quality of the graphics.

Dr Zaius
09 Oct 02, 07:06
Good deal. That seems to correct the problem, although I had a hell of time locating the Direct X control panel in Windows XP. Will changing this setting have any effect on other programs or 3D applications?

Pat Proctor
11 Oct 02, 02:50
I don't think, in DirectX 8, that it will have any effect on 3D apps.

Dr Zaius
18 Oct 02, 16:56
Originally posted by CPT Proctor
I don't think, in DirectX 8, that it will have any effect on 3D apps.

Unfortuantely, this is not the case. Turning off hardware acceleration does fix the problem, but it also caused many of my 3D programs not to load at all. Medieval Total War is one such application. When this option is turned off the game will not even start. Turning it back on fixes the problem.

This is a semi serious issue because I use an NVidia-based graphics card. These are one of the most popular graphics cards among gamers. I was using the reference NVidia detonator drivers when I first encountered the problem. My card was manufactured by Hercules so I downloaded the latest Windows XP driver from them and installed that to see what happens. Same problem as the reference driver from NVidia. This presents a problem. I can go into Windows and turn off the hardware acceleration option so that ATF runs properly, but that screws up other programs in the process. It's a serious issue because it's no fun playing with big pink blobs around the edges of all the units. It's also a pain to reset my Direct X settings every time I want to start ATF.

Any hope this might be corrected in a furture revision?

Pat Proctor
30 Oct 02, 18:46
We have been holding out for a promised (but, as of yet, not delivered) NVidia patch for this problem in their drivers. As it seems this is not forth coming, we are working a patch now that will address the issue.

Dr Zaius
31 Oct 02, 07:18
That's great. Thanks for the update.